• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Afterburn 4.0b Crashes on rendering
I have a scene with a PFlow that increases the number of particles by an object's movement.
The first frames render okay. But when I go to a frame that has more particles, it crashes 3ds max.
When I reduce the number of particles, the same frame that crashed before, starts to work (but other frames with more particles crash).
All the options of environment->afterburn are left in their default, and it doesn't change a thing if I add or remove the light.
I tried to render with multithread enabled and disabled. And it didn't change a thing

So I think it has only to do with particles number.

I'm using 3ds max 2008 - 32 bits

I've uploaded an example file of the error to:

Please, render frame 58

Is that a bug?
Sorry for double posting...
But I've made more tests_
My machine has 4GB of RAM. When I render at frame 40, it already gets the error.
A friend of mine tested it on a 2GB RAM machine, and the problem started at frame 22 (that has less particles).
I think it has something to do with memory. But when I monitor the RAM usage, I see it uses less then 1.6GB. As I have 4GB, I don't know if that is really the issue...
Hi, I took a look at your scene, and I was able to render frame 40. My machine has 2gig of ram with the 3gig switch enabled. Rendering it took 2.5gigs of ram on my task manager.

My observations..
- You are running 3dsmax 32 bit, you won't be able to maximize your 4gig ram. You must use 64-bit for that. (and are running on a 64-bit windows?)
- Maybe try to setup the 3gig switch on your friend's machine and see if it will climb up to 2.5gigs and render.
- Also try increasing the Particle Amount > Upper Limit on your PF Source 01. On your file, it has the default (I think) of 100,000 particles. increase it to a million.
- When using afterburn, I think you don't necessarily have to have a lot of particles, a single particle cloud can represent a lot in an animation.

I hope this helps! Big Grin
Jeff Lim
I've tried render here and it went fine - also using 2Gb RAM machine with 3Gb switch.
You should defeinitely use less particles for AfterBurn volumetrics - it will be faster, using less memory and you'd get the same effect.


Kresimir Tkalcec
That's really strange why it works for you and not for me...
But for the time being I'll try to use less particles.
Thank you both for your replies

Forum Jump:

Users browsing this thread: 1 Guest(s)