• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Max2009 FumeFX TP plugin error
Has anyone installed Max 2009 x64, Cebas Thinking Particles 3 sp1 and FumeFX already?
Did you manage to install the FFX TP plugin?

(all installers latest from cebas and sitni webpage)

When I installed FFX the TP plugin option was not checked - which I found strange since I had TP installed.
Nevermind, I checked the plugin, and installed FFX.
Upon running Max - error.
Not just a tipical one - an almost fullscreen window saying there was a problem accessing E:\3dsmax6(!!!!!)\something something
You may choose to continue but Max will probably screw you anyway.
And offcourse: please send a report to autodesk since Max has crashed.

So I went into FFX directory and deleted the FumeFX_TP.dlo
This time everything worked like a charm.
Fume runs, simulates.
But what is with the tp plugin???

I can provide you a screen capture of the error if you need it.
the Tp plugin needs Thinking Particles to load.. So you need the Max 2009 Tp installed in order to load it..

It gives Extra Sets of Tp operators that can be essencial in procedural fume set ups and \ or interaction with Rigid Body solvers of tp etc..
<!-- w --><a class="postlink" href="http://www.cgfluids.com">http://www.cgfluids.com</a><!-- w -->
But I have TP installed on Max2009 and it works without a problem Sad
So why does ffx_tp plugin mess up?
Maybe its on Sitni Sati side then , and the plugin is not the proper version for 2009 etc.. i would need to check this witch i havent ..
<!-- w --><a class="postlink" href="http://www.cgfluids.com">http://www.cgfluids.com</a><!-- w -->
You knoe me Rif. It's really not my first installation - but a first one with Max 2009.
I will not go through with the upgrade of more mashines until it gets answered.
So please, did anyone install TP3 and FFX on Max 2009 already? Did it work?
Or am I the first one to try it?
I didnt i think joe did ..
<!-- w --><a class="postlink" href="http://www.cgfluids.com">http://www.cgfluids.com</a><!-- w -->
I see the problem, too.

Max 2009 x64
TP 3.0 SP1

When Max starts it gives the error shown in the image.

If FumeFX_TP.dlo is removed from plugin loading, then Max starts okay.

Looks like FumeFX_TP.dlo needs to be fixed.
Well thank you, I'm not alone Smile

Now it's time for Sitni Smile
Hey seriously.
Is ANYONE from Sitni still reading this forum? We have a confirmed bug!
They're usually very responsive. Maybe they're on vacation. Plenty else to work on...

I have noticed that for max 2009, cebas adds [Include] tag at the end of plugin.ini file, in contrast to
older max version where they puts it at the beginning of the file.
You might try to move that tag to ne the first one in plugin.ini file.
Make sure to copy both lines (example below).

cebas plugins=C:\Documents and Settings\All Users\Documents\cebas\3dsmax2009_x64\cebas_plugin.ini

If that does not work, I have recompiled a dlo in the case something was messed up there.

Please let me know if this fix 3ds max startup.


we make sure cebas plugins are loading before everything else...

and we try that new FumeFX_TP.dlo... but it still has same loading problem... exact same error message...
We're experiencing the same problem as described above. The fixes suggested are not working.

When starting up max 2009 it reports an error loading DLLs:
...FumeFX_TP.dlo> failed to initialize.
Error code 126 - the specific module could not be found
Pakuja - do you have Thinking Particles plugin from Cebas installed ?

the -126 error also appears when the DCPFLICS is not properly installed (and look for TSRegisterNow.dll in Max root dir)
sitnisati Wrote:Pakuja - do you have Thinking Particles plugin from Cebas installed ?


Yes we do. To make sure I reinstalled FumeFX after thinking particles.

We run our plungins as floating licences from dedicated licence servers. Also all the plugins work properly on max 2008 and max 9 so I find it hard to believe that it coud be problem with DCPFLICS.

We get no erros if I disable FumeFX_TP.dlo by renaming it as FumeFX_TP.old
The issue occurs in 2009 32-bit too Sad
Im curious if anyone running Max 2009 is not having this problem. Is this an isolated error (I'm also getting this error on Max 2009 32bit) or is this something everyone is experiencing?
Any solution to the problem?

We're still having the problem, I've described above.

Forum Jump:

Users browsing this thread: 1 Guest(s)