• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
sensitivity 0.0 is not the same as 'no' sensitivity?
#1
This compares frame 10 of a huge water explosion. This has a very large ffx box with high expansion, high timescale, and some initial noise. So far, it's got great detail. My question is basically in the subject line. Compare the images below. The top image is sensitivity 0.0 which will be great for saving on ram and sim time, but shows the volume being compressed by the sensitivity box - even at 0.0, whereas the bottom image has it turned off and it looks fine though will be a bear to sim out. btw, this is a crop of what will be HD resolution. Is this a known issue that sometimes high expansion sims will still be 'pushed' by the sensitivity box? try typing that word several times, btw Wink

[Image: ab_fromPre_007--max_sens0_crop.jpg]
[Image: ab_fromPre_007--max_sensNone_crop.jpg]
BRIAN DEMETZ
Senior Technical Director
Final Light VFX
<!-- m --><a class="postlink" href="http://www.finalight.com">http://www.finalight.com</a><!-- m -->
  Reply
#2
Hello Brian,

Do you maybe use a high values of expansion ?
That might be the only factor to mess up our code for adaptive boundary resizing.
If you run a low detail simulation with the same parameters, do you see the same effect ?
If so, can you please forward a file to me.

Thanks

Kreso
  Reply
#3
Yes, the expansion is high. Is this something that will 'mess up the math' so that sensitiviy will cause clipping?. Is there a way to add a sensivity value to the sensitivity value? (kidding Big Grin - kind of) When I get back to the machine that has the file, I'll try a low detail version.
BRIAN DEMETZ
Senior Technical Director
Final Light VFX
<!-- m --><a class="postlink" href="http://www.finalight.com">http://www.finalight.com</a><!-- m -->
  Reply
#4
Hi Brian,

High expansion value could do that to the boundary as expansion feature is not
accounted - and cannot be predicted.

Sorry if that causes trouble.

Kresimir
  Reply
#5
Hi,

I'd like to continue this much older post. Has this ever been resolved? I'm working with some explosions lately that are having the same problem - being flattened on the sides and top with sensitivity set to 0 - they have high expansion and it is needed to achieve the effect.

With sensitivity turned off the blasts look fine but take very long to sim. If there is still no solution, could perhaps a buffer zone be added to sensitivity - an area greater than how the math computes '0' (perhaps in voxels or percentage) so that it's a 'negative' sensitivity that remove the flattening issue?

Thanks!
  Reply
#6
Hello Brian,

The only "proper" grid expansion would be by velocity as velocity field is all that is important. Everything else (except non-adaptive) will result in more or less inaccurate simulation.

Regards,
Kresimir Tkalcec
  Reply
#7
Hi Kresimir,

Thanks for that info. Would 'mixed' also include velocity and therefore use that maximum value? Or would all the channels be averaged and hence for the least flattening i should stay away from 'mixed' and use 'velocity' only? Thanks again!
  Reply
#8
Hello,

Mixed takes fields and velocities in consideration with focus on fields.
Maybe we could add expansion multiplier so it wil be able to expand much more than it is capable now.

Regards,
Kresimir Tkalcec
  Reply
#9
That would be awesome! Thanks again.
  Reply


Forum Jump:


Users browsing this thread: 1 Guest(s)