• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Gridline Horizontal Artifacts - with Advection Fields
Hi all,

I'm doing a sim with some thick smoke trailing some fire that moves through screen relatively quickly. There seem to be some horrible horizontal artifacts appearing throughout the sim. I've read some other posts on what sounds like a similar problem but haven't been able to solve it for my sim yet. I've tried raising my high threshold of the smoke renderer, higher rez grids, low spacing on renders, jitter etc. It looks a little like the picture in the FumeFX help depicting artifacts in an 'advect fields and vel' render.. but mine is standard 'advect fields'. Attached is a section of a render where they are particularly bad. It's almost like the smoke is catching on the grid. My smoke was simmed at a density of ten modified with the smoke render curve.

Any help would be much appreciated.

Advanced (fields and vels) advection operates on all fields and velocities as well. This type of advection is excellent for slow moving fluids while highly divergent and fast moving fields might result in artifacts in a form of lines or crosses. Keep in mind that this advection is very good in preserving small scale detail, so vorticity value can be kept really low (around 0.1).

Quote from FumeFX 2.1 help
Thanks Wasus,

I did read that, but was of the understanding that the quote only applied to the Advanced (fields and vels) advection. I'm currently using Advanced (fields) and was hoping that there may be a way to solve the problem without switching back to Default Advection, because I'm really happy with the fire in my sim and was hoping to avoid trying to match it in Default. It may be that this is just an inherent problem with either field advection.. in which case I won't have a choice.

Thanks again for your reply.
Hi ajones,

Yes, this is unfortunate artifact with Advanced advection and we are looking if it can be solved.
There is one option that might help lessen this artifact by using non-adaptive grid, or try to set adaptive grid sensitivity to 0.0.
It won't make it go away, but it might be much less apparent.


Forum Jump:

Users browsing this thread: 1 Guest(s)