• 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
runsimulation() bug
this might be a bit minor but maybe this works on

I found that runsimulation(0) triggers a system exception unless the fume edit ui is on first.

If I open a file, and run mxs cmd runsimulation(0) a system exception occurs and max crashes,

the mxs cmd "myFumeObj.EditUI = on" doesnt work.

If I open the cmd pannel by clicking on it, then running the sim maxscript command a simulation successfully triggers.

open a max file
causes a system exception

open a maxfile
FumeGridObj.editUI = on

causes a system exception

open a maxfile
clicking the fume grid and manually opening the fume window

runs a successful simulation

I'm going to keep on pokeing around and see if I can get a workaround going. Thx.

Fumefx 2

and it seems like I cant set any values without opening the fume panel first.

myFumeObj.simmode = 0 causes a system exception aswell

the same problems persist when tried with a simulation licenese
Bleh...this fixes it

actionMan.executeAction 12121256 "40011"
$PyroCluster_R_V0158.EditUI = on
Thanks for reporting this bug.
I will have to dig what is it all about, but I am glad that you have found a workaround.

Hi Andrew,

I tried both max 9x64 and max 2010x64 for scripts like $FumeFX01.RunSimulatio(0) right after
scene load and it worked fine. Could it be scene specific ?

Not sure but I had to do the same technique as Andrew to get Jeff Lim's FumeFX Partitioner Script running with Fume 2.0

Forum Jump:

Users browsing this thread: 1 Guest(s)